Integracion de Twilio a Glide

Hola comunidad!!!

Actualmente estoy finalizando mi aplicativo que pronto espero mostrarles, pese a la deficiencia de glide con respecto a las push notifications he llegado a la conclusión que me conviene trabajar con Twilio, pero sucede que tengo un par de dudas al respecto:

-¿por obligación debo usar Zapier?
-¿es requisito pagar un plan en zapier para poder trabajar?
-¿existe una mejor forma de integrar twilio a glide???..

de antemano, estoy agradecido con sus respuestas, se que me serán de utilidad

:v:t5:

Puedes conectarlo a través de App Script en tu GoogleSheet. En la página de Twilio te dice cómo:

Saludos

3 Me gusta

mil gracias Wilder, ya lo estoy estudiando

:v:t5:

1 me gusta

Aporte de @WilderYoung

3 Me gusta

En vez de Zapier, puedes usar Integromat, es más económico y funciona igual de bien.
Saludos

2 Me gusta

Hey, te mandaste @jorgevaldez … Gracias!!! @wilderyoung

1 me gusta

Hey Gracias, ya apunto a Integromat en lo pendiente de estudio
:v:t5:


Saben… a pesar de la sencillez y claridad que lo explicaste, me da ese error; Creí que la credencial y el token de la cuenta de Twilio que use en primer instancia era la del problema, así que cree otras 2 pero me sigue dando ese error.

La verdad seguí con lupa los pasos mostrados en el video, he entendido la logica y funcionalidad del código, he revisado todos lo símbolos, he leído la documentación de twilio y no logro dar con una solución viable, a alguien ya le sucedió lo mismo?

Este es el código exacto que estoy usando:

function enviarSMSNUEVOPEDIDO(){

var accountSid = “xxxxxxxxxxxxxxxxxxxxxe0fe3c372214ff2”;

var authToken = “xxxxxxxxxxxxxxxxxxxxxxxx27c823cab4f5”;

var numeroTwilio = “+xxxxxxxxxx”;

var messages_url = “https://api.twilio.com/2010-04-01/Accounts/”+ accountSid +"/Messages.json";

var payload = {

"To" : "+xxxxxxxx",

"Body" : "prueba",

"From"  : numeroTwilio

};

var options = {

"method" : "post",

"payload" : payload

};

options.headers = {

“Authorization” : “Basic” + Utilities.base64Encode(accountSid +":"+ authToken)

};

UrlFetchApp.fetch(messages_url, options);

}

ya dejo el drama… :crazy_face: :crazy_face: :crazy_face: aqui estaba el problema:
-luego de “Basic” lleva 1 espacio y queda "Basic "

todo funcionando al 100% gracias :rofl: :rofl:

1 me gusta

Hola por el mensaje que devuelve el error parece que el el token o o el sid son el error